The fastest message board... ever.
 
Update issues
Posted by: divewithkarim ()
Date: October 16, 2014 08:28PM

Hi Matthias

If possible to send me links to bootloader v1 and any old stable version of the firmware.

I tried to connect my dead OSTC and tiny bootloader found it on COM3, I tried again to update & this is what I get:

Connected to \\.\COM3 at 115200
HEX: 0 min old, INHX32,18Fcode+cfg, total=92240 bytes.
Searching for PIC ..., Not found
ERROR!
Not found!

Still my OSTC is dead.. Help please



Edited 1 time(s). Last edit at 10/16/2014 08:50PM by heinrichsweikamp.

Options: ReplyQuote
Re: Update issues
Posted by: heinrichsweikamp ()
Date: October 16, 2014 08:56PM

Hi,

(I moved this issue into a separate thread).

Your're still using the bootloader v2. It won't wake-up your OSTC from this state. Please don't try anything with the bootloader v2 with your unit. It's possible that you damage it permanently.

As told, please use the bootloader v1. It's all written in this post: [forum.heinrichsweikamp.com]

Read the section beginning of "If you have firmware <1.90:"

If you have firmware <1.90:

3: Step:
Update process (Windows):
- Download Bootloader v1 program: [www.heinrichsweikamp.com]
- Download the correct HEX file! The file for the Mk.2 is called "mk2_v280_stable.hex", for example. [www.heinrichsweikamp.com]
- Choose correct HEX file in the bootloader file dialog: "Browse"
- Choose correct COM-Port in the bootloader (The bootloader searches all COM-Ports automatically)
- In the OSTC Mk.2 Reset Menu, choose "Reboot OSTC" and confirm
If the Menu entry "Reboot OSTC" is not available (e.g. a wrong firmware has been installed), the reset can be triggered with a magnet on the back of the OSTC Mk.2. "Reboot OSTC" and the magnet have the exact same effect on the OSTC Mk.2
- Press "write" at the bootloader within 10 seconds
- Wait about 1min.

Hope this helps,
Matthias

Options: ReplyQuote
Re: Update issues
Posted by: divewithkarim ()
Date: October 16, 2014 09:37PM

Hi Matthias

Posted the following in Firmware3:

I tried bootloader V1 and JDivelog to resuscitate my OSTC2, even my PC system manager recognize the port COM3 when OSTC2 is plugged. But JDiveLog is sending: Could not establish handshake. Did you press RESET? And Bootloader V1 is showing the following:
ootloader for HeinrichsWeikamp OSTC,
based on TinyBootLoader, v.1.9.5 written by claudiu.chiculita@ugal.ro
[www.etc.ugal.ro]
Support: info@heinrichsweikamp.com
--------------------------------------------------------------------------------------------------

Connected to \\.\COM3 at 19200
HEX: 3 hours old, INHX32,18Fcode+cfg, total=92679 bytes.
Searching for PIC ...Not found,
ERROR!.

I'm using a magnet during the all process, but confused smiley.

Help please.

Options: ReplyQuote
Re: Update issues
Posted by: scubatinoo ()
Date: October 17, 2014 10:10AM

My advice: Don't use JDivelog for firmware updates... In the past i had several issues with JDivelog and as far as i know the software is not up to date with the OSTC-Firmware...

You should have a look at OSTCPlanner (https://ostc-planner.net/wp/download/) instead. This software worked always for me, both on Mac and Windows!

regards,
scubatinoo

><((((º> OSTC 2N 3705 <º)))><

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.