The fastest message board... ever.
OSTC's running hwOS 
Issue to export from Subsurface w/ OSTC Sport V10.35
Posted by: Motardplongeur ()
Date: August 06, 2017 01:41PM

Hello

Since V10.35* on my Sport, I can't export dives from Subsurface to CSV files ; Subsurface answer 'failed to read XML memory' (red band on the bottom of the screen) and no file is created.

If I try to export to a XML file, it create the file but empty, just a warning:
"Erreur d’analyse XML : mal formé
Emplacement : file:///C:/Users/chris/Desktop/toto.xml
Numéro de ligne 23, Colonne 59 : <extradata key='Deco model info' value='Saturation 77, D?}???}???' />
----------------------------------------------------------^
"

No issue to export from Sport to Subsurface & no issue with dives exported by V10.34 or older versions.

I put a message on Subsurface forum but no answer (https://subsurface-divelog.org/user-forum/, win section, same author).

I use Win10, all softwares are updated.

*Dives with issue have been performed with V10.35 and exported to Subsurface with V10.35 and 37, same problem.

Can you help me ?

Thanks.

Les pieds dans l'eau, la tête dans les étoiles

Options: ReplyQuote
Re: Issue to export from Subsurface w/ OSTC Sport V10.35
Posted by: glance ()
Date: August 06, 2017 10:55PM

Your xml file looks damaged, due to a bug in subsurface, thats fixed in the current development tree.

Open toto.xml and cleanup that Deco model info row or just delete it and things will work again.


//Anton

Options: ReplyQuote
Re: Issue to export from Subsurface w/ OSTC Sport V10.35
Posted by: Motardplongeur ()
Date: August 07, 2017 08:07PM

Thanks

It works (to have readable XML file, not for CSV)

Hoping this issue will be solved in the next Subsurface update.

Les pieds dans l'eau, la tête dans les étoiles

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.