OSTC 4 :  heinrichs weikamp forum The fastest message board... ever.
 
1.4.4 beta
Posted by: heinrichsweikamp ()
Date: February 06, 2019 11:03AM

Hi everyone,

After the fail with the 1.3.9 (Not supporting older hardware properly) we're carefully making small steps for the new stable.

Attached to this post is the latest beta 1.4.4

regards,
Matthias

Attachments: OSTC4update_190204.zip (317.8 KB)  
Options: ReplyQuote
Re: 1.4.4 beta
Date: February 07, 2019 12:33PM

Hi,

I tried to install this version on my OSTC4 (#82)

But no matter what I tried (removed battery, (waited), reboot RTE, reboot firmware, installed old version en redid the whole process (including remove battery)) ... always it came up with the same message UPDATE RTE.

Back to my old version....

Peter

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: heinrichsweikamp ()
Date: February 07, 2019 12:34PM

Hi,

Did both parts upload? If not, you can restart the update and only the missing part (in this case the RTE) will be installed.

regards,
Matthias

Options: ReplyQuote
Re: 1.4.4 beta
Date: February 07, 2019 02:27PM

Matthias,

I did that..

First time installed part 1,2 and 3...waited till shutdown ... waited some more .. then installed 3 again... with message UPDATE RTE

Did the install again but with variations.. on reboot RTE, reboot Firmware and remove battery... tried different sequence, different wait time... etc ... last step was always the same... install part 3... result also always the same... UPDATE RTE...

Peter

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: jlm ()
Date: February 13, 2019 03:30PM

Hi Matthias,

the OSTC4 arrived, so I immediately tried to upgrade it to the "latest and greatest" version :-) Obviously, as a Linux/Unix guy it was some fiddling around with the Windows based OSTC companion, but I finally succeeded in my first ever flash of an OSTC4. See the following log:


OSTC4 selected.
Connecting...
Found OSTC4 #0451, fw 203.08 (main 1.03.05beta/RTE 1.06.00/Font 0.09.00), JLM
Connected: OSTC4 #0451, fw 203.08 (main 1.03.05beta/RTE 1.06.00/Font 0.09.00), JLM
Disconnecting...
Disconnected.
Upgrading firmware...
Starting OSTC4 firmware upgrade...
uploading part 1: FW v1.04.04 beta...
part 1: FW v1.04.04 beta uploaded.
uploading part 2: Font v1.00.00...
part 2: Font v1.00.00 uploaded.
uploading part 3: RTE v1.05.01...
part 3: RTE v1.05.01 uploaded.
Please wait for OSTC4 to complete installation...

And I immediately see something strange. I had RTE 1.06.00, its flashing RTE v1.05.01, and as Peter above, I see a flashing red "Please update RTE". Further, almost all data on the "home screen" is wrong, the is a small counter running in the top "spi error" with changing numbers.

It feels like the wrong RTE version is packed in this 1.4.4 beta ...


--jan



Edited 2 time(s). Last edit at 02/13/2019 04:04PM by jlm.

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: jlm ()
Date: February 13, 2019 11:00PM

Ok, went some steps further, and compiled firmware and RTE from source based on SHA 98fb81f (tip of kittz branch), as that is what I think corresponds to the forum release 1.4.4.

Exact same problem including the strange RTE 1.5.1. So, its simple. That branch does not run. There is nothing wrong with the packaging, as I composed a set of Firmware 1.4.4, Fonts 1.0, and RTE 1.6 and that one has also the exact same problem. But I managed to produce a running set of Firmware 1.4.0, Fonts 1.0, and RTE 1.6.

--jan

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: mahug ()
Date: February 22, 2019 04:32PM

Hi,
what's new in Version 1.4.4?
Can provide Release Notes or a changelog please?

Thanks

Markus

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: swissdiving ()
Date: March 07, 2019 06:39AM

We have not had a stable since 1.3.0 (2017).
When are we going to get a new stable (not to speak of new features!).
: (

Cheers,

Hansjoerg

--> 2N ¦ 2201 / 3892
--> OSTC4 ¦ 257 / 392 / 424

RTFM

Options: ReplyQuote
Re: 1.4.4 beta
Posted by: heinrichsweikamp ()
Date: March 10, 2019 10:17AM

swissdiving Wrote:
-------------------------------------------------------
> We have not had a stable since 1.3.0 (2017).
> When are we going to get a new stable (not to
> speak of new features!).
> : (

When it's ready. Please let us work on that and let us do some proper testing before releasing it. There's a lot happening to the OSTC4 code currently...

regards,
Matthias

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.