OSTC Plus Charging

OSTC's running hwOS sport or tech
Post Reply
Neil R
Posts: 1
Joined: Sunday 24. April 2022, 17:15

OSTC Plus Charging

Post by Neil R »

It's about time I asked for some help with my OSTC Plus, I've been having charging issues since this was bought new just under 2 years ago.

A typical charge cycle attempt is as follows:
- Within the first minute or so the charger goes to red blinking
- Then after roughly 20 mins it goes green and starts to charge. It adds maybe 10 to 15 percent, then seems to stick at that value. And it seems to get quite warm.
- Since it seems to stay warm and do nothing further, I manually stop the charging, wait 30 mins or so for things to cool, and start again.
- It typically takes 3 to 4 cycles to get close to, but mostly never quite, 100%.
- Despite achieving say 99% charge (and showing 4.1v), I regularly get low battery status messages even during single day dive trips. Yesterday I suffered a complete reset (date etc) I suspect sometime between the first and second dives. It does still work ok underwater though (even when showing 0%).

This is with the second red 3.7v Sanyo battery that I have tried. The first (as supplied) Sanyo behaved the same, as did the slightly longer Keeppower cell (from Deep Ideas) that I also tried. It is set to T2.
The only way I see 100% reliably on the OSTC is if I charge the cell externally first, select it as a new cell, then put it on induction charge. It goes to the green 100% pretty quickly then.
I have tried one Samsung 2A USB supply, and two different Anchor 2.4A supplies.
All the internal contacts etc look clean.
I'm still on 10.66 software. I'd update this, but I haven't yet managed to solve the com port issue.

I hope you can help!

(edited to correct Sony to Sanyo).
Post Reply